TrueCrypt on OS X Snow Leopard

19 Feb 2011

It seems that there is a generalt notion out there that Snow Leopard breaks the support for TrueCrypt on OS X.
It is true that you are unable to mount encrypted files after install. I got an error saying something like macfuse file system not available.
There exists an easy fix for this though:
The problem seems to be caused by a dependency, MacFuse, that does not work with the 64bit verison of OS X. I solved this by installing another binary of MacFuse that supports 64bit OS X.
It can be found here. If you do not trust the source it may be possible to install MacFuse
through MacPorts with 64bit support, I have not confirmed this though. If you know more about this please drop a comment below.

blog comments powered by Disqus